Cuaderno Virtual

Algoritmos resueltos en Pseint

Escrito por laesperanza12 28-09-2010 en General. Comentarios (1)

1 Proceso edad

                Escribir "edad";

                Leer edad;

                Si edad>36 Entonces

                               Escribir "eres maduro";

                Sino

                               Escribir "que joven eres";

                FinSi

FinProceso

2 Proceso triangulo

                Escribir "ingrse la altura del triangulo";

                Leer h;

                Escribir "ingrese la base del tringulo";

                Leer b;

                a<-b*h;

                Escribir  " el area de triangulo es", a;

FinProceso

Mecanismos

Escrito por laesperanza12 15-09-2010 en General. Comentarios (0)

Toda máquina compuesta es una combinación de mecanismos; y un mecanismo es una combinación de operadores cuya función es producir, transformar o controlar un movimiento.

Los mecanismos se construyen encadenando varios operadores mecánicos entre si, de tal forma que la salida de uno se convierte en la entrada del siguiente.

Propuesta

Escrito por laesperanza12 15-09-2010 en General. Comentarios (0)

El ascensor está constituido por un motor y una estructura de madera con su respectiva función, el ascensor se elabora poniendo el motor y creando una base para el sistema de movimiento de subir y bajar

Publicidad

Escrito por laesperanza12 09-09-2010 en General. Comentarios (0)

La publicidad tiene como fin dar a conocer los bienes y servicios al público con el objetivo de motivarlos a que lo consuman. Estos articulos se dan a conocer por los medios de comunicación.

PseInt

Escrito por laesperanza12 08-09-2010 en General. Comentarios (0)

Es una herramienta de fácil manejo que por su interfaz grafica permite crear, ejecutar y corregir fácilmente programas en Pseudocódigo.

Permite escribir programas con instrucciones condicionales, en ciclos y también valores numéricos.

Pseudocódigo: el pseudocódigo no se puede mejorar pero facilita la programación.

 

 

EJEMPLOS

 

- A un trabajador le pagan según sus horas trabajadas y la tarifa esta a un valor por hora. Si la cantidad de horas trabajadas es mayor a 40 horas, la tarifa por hora se incrementa en un 50% para las horas extras. Calcular el salario del trabajador dadas las horas trabajadas y la tarifa

 

SOLUCION

 

ENTEROS horas_trabajadas, tarifa,horas_extras, salario, tarifa_extra

INICIO

LEER horas_trabajadas<=40 Entonces

Salario<-horas_trabajadas*tarifa

SINO

Tarifa_extra<-tarifa+0.50*tarifa

Horas_extras<-horas_trabajadas-40

Salario<-horas_extras*tarifa_extra+40*tarifa

FIN SI

ESCRIBIR salario

FIN

 

- En un instituto se llevara a cabo un paseo para 30 estudiantes, al cual solo podran asistir los estudiantes de programacion y mantenimiento, deseamos saber cuantos estudiantes de mantenimiento y programacion asistiran a la salida.

 

SOLUCION

 

Proceso estudiantesPseint
programacion<-0
mantenimiento<-0
Para i<-1 Hasta 30 Con Paso 1 Hacer
Escribir 'digite el programa en el que esta inscrito: '
leer programa
si programa= 'mantenimiento' Entonces
mantenimiento<-mantenimiento+1
Sino
si programa= 'programacion' Entonces
programacion<-programacion+1
FinSi
FinSi
FinPara
Escribir 'estudiantes de mantenimiento: ',mantenimiento
Escribir 'estudiantes de programacion: ',programacion
FinProceso

- Un estudiante tiene las calificaciones de 11 logros, pero solo quiere obtener el promedio de los logros aprobados.

 

SOLUCION

 

Proceso LogrosPseint
numeronota<-0
totalnota<-0
Para i<-1 Hasta 11 Con Paso 1 Hacer
Escribir 'digite la nota del logro:',i
leer nota
si nota>=3.0 Entonces
numeronota<-numeronota+1
totalnota<-totalnota+nota
FinSi
FinPara
promedio<-totalnota/numeronota
Escribir 'el promedio de los logros pasados es: ',promedio
FinProceso

- Una empresa desea saber de un grupo de 8 empleados el total de salarios que paga mayores al salrio minimo legal vigente (461500).

 

SOLUCION

 

Proceso salariototalPseint
salariototal<-0
Para i<-1 Hasta 8 Con Paso 1 Hacer
Escribir 'digite el salario del empleado ',i
leer salario
si salario>461500 Entonces
salariototal<-salariototal+salario
FinSi
FinPara
Escribir 'El total de salarios es: ',salariototal
FinProceso

 

 

 

 

 http://pseint.sourceforge.net/manual.html#Introducci.C3.B3n